31 Schrauben raus …

MacBook Pro… und wieder reingeschraubt, um die 250 GB-Platte im 17″ MBP gegen eine 320er zu wechseln. Und vermutlich genau so viele, um die jetzt frei gewordene 250er gegen die 160er im 15″ MBP zu wechseln. Bei meinem alten Dell war es nur eine, um die Plattenhalterung heraus zu bekommen und dann nochmal vier, um die Platte aus der Halterung zu holen. Aber Qualität benötigt halt mehr Schrauben!!! 😉

31 Schrauben raus …

Cisco ASA 8.0 Layer7 Inspections

Die Layer7-Protokoll-Inspizierungen lassen sich auf der ASA per ASDM recht komfortabel konfigurieren. Manchmal kommt man aber an der Kommandozeile nicht vorbei. Um die Verwendung der Komponenten innerhalb der L7-Policy etwas besser zu verstehen, habe ich ein Diagramm angefertigt, das die Verbindungen der Komponenten untereinander darstellt.

Download: asa-policy-thumb

Cisco ASA 8.0 Layer7 Inspections

IPv6 für den Massenmarkt

Von Zeit zu Zeit frage ich bei verschiedenen Herstellern an, wie es mit der Unterstützung von IPv6 aussieht.
Hier die aktuelle Antwort von AVM bezüglich der Fritz-Box:

Hallo Herr Iwen,

bedaure, ein solches Produkt haben wir nicht im Programm aber
vielen Dank für Ihre konstruktiven Verbesserungsvorschläge,
sie wurden von mir soeben an den dafür zuständigen Produktmanager
im Hause AVM weitergeleitet. Ob und ggf. wann eine Umsetzung
erfolgen wird, steht zum jetzigen Zeitpunkt allerdings
noch nicht fest. Generell gilt aber natürlich, daß unsere
Produkte von der Nachfrage und den Verbesserungsvorschlägen/
Wünschen der Kunden “leben”, so wurden auch in der Vergangenheit
bereits unzählige Verbesserungsvorschläge in die Tat umgesetzt
(nicht selten schon direkt in der nächsten Version).

Mit freundlichen Grüßen

Und die Antwort von Versatel bezüglich der Verfügbarkeit von IPv6 für Endkunden:

Guten Tag,

vielen Dank für Ihre Anfrage vom 20.01.2009. Sie hat die
Bearbeitungsnummer 2410763 erhalten.

Vielen Dank für Ihr Interesse an “IPv6”

Auch wir verfolgen den Markt für “IPv6” intensiv. Versatel prüft
derzeit, inwieweit es auf dieser Technik basierende Produkte entwickeln
und anbieten wird. Aus diesem Grund können wir Ihnen zum jetzigen
Zeitpunkt keine detaillierte Auskunft geben, wann und ob “IPv6” in naher
Zukunft anbieten können.

Wir wünschen Ihnen einen schönen Tag.

IPv6 für den Massenmarkt

Die Adressvergabe des IOS DHCP-Server

Wenn man im IOS einen DHCP-Server konfiguriert, kann man Adressen von der Vergabe ausschließen. Manche Adressen muss man aber nicht ausschließen, da der Router sie selbständig erkennt.
Dazu das folgende Beispiel:

dhcp-lab

R1 ist der DHCP-Server mit einigen Optionen und zwei Loopback-Interfaces, die im Zielnetz liegen:


ip dhcp pool test
   network 10.0.35.0 255.255.255.0
   dns-server 10.0.35.2 
   default-router 10.0.35.3 
   netbios-name-server 10.0.35.4 
   option 72 ip 10.0.35.5 
   option 150 ip 10.0.35.6
!
interface Loopback35
 ip address 10.0.35.1 255.255.255.255
!
interface Loopback36
 ip address 10.0.35.7 255.255.255.255

R5 ist der DHCP-Client:

interface FastEthernet2/0
 ip address dhcp

In diesem Scenario gibt der DHCP-Server dem Client IP-Adressen in der folgenden Reihenfolge: 10.0.35.2, .4, .5, .6, .8.

Der DHCP-Server vergibt also keine Adressen, die er eigenen Router-Interfaces zuordnen kann. Für weitere Adressen, auch wenn man sie als Option im DHCP-Pool verwendet, muß man Ausnahmen definieren. Die Adresse des Default-Routers wurde durch einen Ping-Test herausgefunden und deshalb auch nicht verwendet. Ähnlich verhält sich der DHCP-Server mit HSRP. Sowohl die virtuelle IP (wenn sie nicht auf dem DHCP-Server aktiv ist), als auch die Adressen der HSRP-Nachbarn werden nicht automatisch ausgeschlossen.

In diesem Beispiel habe ich 12.4(15)T8 AdvEnterprise-Images verwendet.

Die Adressvergabe des IOS DHCP-Server

User-Agents auf security-planet.de

Gerade bin ich dabei, für ein ASA-Projekt die HTTP-Policies zu schreiben. Als Vorlage habe ich ein paar User-Agents der verwendeten Browser von dieser Seite extrahiert. Und was sehe ich da, unter anderem?

  • Opera/7.54 (Windows NT 5.1; U)
  • Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)
  • Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
  • Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8) Gecko/20051111 Firefox/1.5
  • Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
  • Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.10) Gecko/20050717 Firefox/1.0.6
  • Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)
  • Mozilla/4.0 (compatible; MSIE 4.01; Digital AlphaServer 1000A 4/233; Windows NT; Powered By 64-Bit Alpha Processor)
  • Mozilla/5.0 (X11; U; FreeBSD i386; de-DE; rv:1.8.1.10) Gecko/20071208 Firefox/2.0.0.10

Ja Leute, wollt ihr mich hier vera***en? Das meint ihr doch wohl nicht ernst?

User-Agents auf security-planet.de