Internet Risk Behaviour Index

Vorhin sitze ich an meinem Linux-Rechner, lese nebenbei die <kes> und stoße dabei auf folgende Anzeige:

Wie sicher sind Ihre Mitarbeiter im Umgang mit dem Internet?
Finden Sie es heraus!
Nutzen Sie dazu unsere Simulation riskanter Online-Szenarien
www.irbi.de

Das fand ich ja erst einmal interessant und ich rufe die Seite auf. Und was springt mir da als erstes entgegen?

irbi

Bisher ist mir im Internet noch nie eine Seite begegnet, die Silverlight erforderte. Und nun das erste Mal gleich auf einer Seite, auf der es um IT-Security geht …

Klarer wurde es, als ich ins Impressum geschaut habe:

Microsoft Deutschland GmbH
Konrad-Zuse-Straße 1
85716 Unterschleißheim

Advertisements
Internet Risk Behaviour Index

Wiederherstellung des Apple Macs nach dem 10.5.6-Update

Apple OS XGestern wollte ich mein zweites MacBook Pro mit dem neuesten MAC OS-Update bestücken. Leider brach das Update ab und nach einem Neustart bootete der Rechner nicht mehr (ein Fehler, den ich in etlichen Jahren mit XP nie hatte 😦 ). Auf folgende Art und Weise habe ich ihn wieder zum Leben erweckt:

  1. Download des 10.5.6 Combo-Update auf meinem ersten Mac (der auch nach dem Update noch lief)
  2. Verbinden beider MACs per Firewire-Kabel
  3. Starten des Problem-MACs im Target-Disk-Mode (“T” beim Start drücken), die HD wird auf dem anderen MAC eingebunden
  4. Das Update aufrufen und das Installations-Ziel auf die per FireWire eingebundene Platte ändern

Nach diesem Update liess sich mein Mac wieder ganz normal starten.

Und was lernen wir daraus?

  • Der MAC ist nicht bei allem besser als Windows
  • Besser einen MAC mit Firewire kaufen (was Dank der inzwischen zweifelhaften Produkt-Politik von Apple natürlich schwieriger wird)
  • Update1: Immer besser das Combo-Update nehmen (danke Chris, auch das sollte man daraus lernen)

Vielleicht hilft das ja jemandem. Das Internet ist voll mit Problemberichten durch das Update, aber viele Lösungsbeschreibungen gibt es leider nicht.

Update2: Vermutlich muss man nach dieser Art der Aktualisierung im Festplatten-Dienstprogramm noch die Zugriffsrechte reparieren. Im Target-Mode wird die Festplatte ohne Anwendung von Benutzerrechten gemounted und daher sind diese dann vermutlich falsch gesetzt. Das werde ich heute Abend noch einmal kontrollieren. Die Berechtigungen waren alle ok. Die Überprüfung aus dem Festplatten-Dienstprogramm hat nichts hervorgebracht.

Wiederherstellung des Apple Macs nach dem 10.5.6-Update

Läuft Policy-Routing im CEF-Switching-Pfad?

Diese Frage wurde mir vor kurzem in einem Cisco-Routing-Workshop gestellt und ich habe mit einem überzeugten “Ja, klar!” geantwortet, um es ein paar Sekunden später mit einem “naja, bin ich mir fast sicher, daß PBR im CEF-Pfad läuft” zu relativieren. So ziemlich alles, was irgendwie “durch” den Router geht, ist inzwischen CEF. Aber kleine Ausnahmen, mit denen man nicht rechnet, kann es natürlich immer geben.

Deshalb habe ich das mal schnell in einem 12.4(20)T nachgestellt:
policy-routing-topology

Die Konfiguration (der relevante Part) des rechten Routers:

hostname R2
!
interface FastEthernet1/0
 ip address 10.1.1.2 255.255.255.0
!         
interface FastEthernet1/1
 ip address 10.1.2.2 255.255.255.0
 ip policy route-map POLICY-TEST
!         
interface FastEthernet2/0
 ip address 10.10.1.2 255.255.255.0
!
ip route 1.1.1.1 255.255.255.255 10.1.1.1
ip route 3.3.3.3 255.255.255.255 10.1.2.3
!
ip access-list extended POLICY-ACL
 permit icmp host 3.3.3.3 host 1.1.1.1
!
route-map POLICY-TEST permit 10
 match ip address POLICY-ACL
 match length 100 200
 set ip next-hop 10.10.1.1
! 

Diverse Pings vom PC auf die Adresse 1.1.1.1 mit Größen von 150 und 250 Bytes zeigten auf R2 folgendes Ergebnis (die Counter passen nicht genau, da ich diese zwischendurch mal gelöscht habe):

R2#sh route-map          
route-map POLICY-TEST, permit, sequence 10
  Match clauses:
    ip address (access-lists): POLICY-ACL 
    length 100 200
  Set clauses:
    ip next-hop 10.10.1.1
  Policy routing matches: 25 packets, 3570 bytes
R2#

R2#sh int fast 1/1 stats 
FastEthernet1/1
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
               Processor          1         77          0          0
             Route cache         45       6400         40       5500
                   Total         46       6477         40       5500
R2#

R2#sh ip cef switching statistics  feature 
IPv4 CEF input features:
Path   Feature             Drop   Consume  Punt  Punt2Host Gave route
RP PAS Policy Routing         0         0     0          0         10
Total                         0         0     0          0         10

Im nächsten Test habe ich dann zusätzlich noch NAT aktiviert, denn der Teufel steckt manchmal im Detail bzw. beim IOS in der Kombination der Funktionen. Aber auch dabei gab es nur CEF-geswitchte Pakete. Puh, Glück gehabt … 🙂

Läuft Policy-Routing im CEF-Switching-Pfad?

Nmap Network Scanning

Nur für den Fall, daß hier jemand die nmap-hackers-Mailingliste nicht liest:
Das Buch des Nmap-Autors “Fyodor” ist jetzt erschienen und kann bestellt werden. Der Abstrakt beschreibt das Buch:

Nmap Network Scanning is the official guide to the Nmap Security Scanner, a free and open source utility used by millions of people for network discovery, administration, and security auditing. From explaining port scanning basics for novices to detailing low-level packet crafting methods used by advanced hackers, this book by Nmap’s original author suits all levels of security and networking professionals. The reference guide documents every Nmap feature and option, while the remainder demonstrates how to apply them to quickly solve real-world tasks. Examples and diagrams show actual communication on the wire. Topics include subverting firewalls and intrusion detection systems, optimizing Nmap performance, and automating common networking tasks with the Nmap Scripting Engine.

Da das Buch wohl noch zu neu ist, kostet es zur Zeit bei Amazon.de in Euro (EUR43,99) mehr, als bei Amazon.com in US-Dollar ($33,71). Ich habe meine Version deshalb bei einem Amazon-Marketplace-Händler bestellt (EUR 29,71).

Ich bin sehr gespannt auf das Buch. In ein paar Tagen sollte es geliefert werden.

http://rcm-de.amazon.de/e/cm?t=lan2wan-21&o=3&p=8&l=as1&asins=0979958717&fc1=000000&IS2=1&lt1=_blank&m=amazon&lc1=0000FF&bc1=000000&bg1=FFFFFF&f=ifr

Nmap Network Scanning

Feed me!

Im Zockertown-Blog habe ich von der T-Shirt-Aktion von 3dsupply.de gelesen. Als altem T-ShirtJäger war mir sofort klar: Da muss ich mitmachen! Also, her mit dem “Feed me!”-Shirt. 🙂

Update: Und fast bereue ich es schon, da mitgemacht zu haben. Etliche Blogger posten in ihren Beiträgen eine komplette Liste der teilnehmenden Webseiten, um darüber Backlinks zu sammeln. Das ergibt so viele “bitte moderieren”-Mails, daß sogar die Spammer neidisch werden könnten …

Feed me!

Welches Cisco IOS sollte man verwenden?

Ok, eigentlich lässt sich diese Frage nicht wirklich allgemein beantworten. Trotzdem wird sie mir häufiger mal gestellt. Ohne auf die nähere Umgebung eines Fragestellers einzugehen, war meine bisherige Antwort meist: “Ein relativ neues und gut gepatchtes MD-Release wie das 12.4.13f. Oder 12.4(15)T7 wenn man die neuesten Funktionen benötigt oder VPNs einsetzt”.

Seit dem 3. Dezember ist aber das IOS 12.4(15)T8 verfügbar. Dieses hat Cisco, obwohl es ein T-Release ist, zum Maintenance Deployment (MD) befördert und verspricht Updates bis Dezember 2010.

Von daher wird sich in Zukunft meine Antwort auf solche Fragen vermutlich auf folgendes reduzieren können: “Das neuste 12.4(15)T-Release.”

Welches Cisco IOS sollte man verwenden?